3D, VR and 360° Photographers  |  Real Estate Agents  |  3rd Party Service Providers
Need a 3D/VR/360°/Drone Photographer? 2,563 We Get Around Network Members in 90 Countries! Ask For FREE referral!
We Get Around Network Forum
Basic Fuse private msg quote post Address this user
Hi

When we publish on FB we got a image of Logo Matterport. I wish to have my own picture instead. Do anyone have a solution to this?
Post 1 • IP   flag post
Richard private msg quote post Address this user
Use the embed link instead of URL link?
Post 2 • IP   flag post
3rd Party Service rpetersn private msg quote post Address this user
I've built WP3D Models (a WordPress-based plugin) that solves this very issue, and here's a blog post that covers the topic in more detail:

http://wp3dmodels.com/2015/09/wp3d-models-wordpress-plugins-easy-social-media-integration/

Please let me know if you have any questions!
Post 3 • IP   flag post
Richard private msg quote post Address this user
...and if you have a thumbnail preset on the scan - when using the embed link - your designated embed link will show this picture in the FB feed.
Post 4 • IP   flag post
3rd Party Service rpetersn private msg quote post Address this user
@Richard That's exactly right....the only drawback is that the URL from Facebook goes back to Matterport, and not your own website. You won't know how many people clicked and/or how much traffic your post generated. Additionally, there's no way to customize the image that appears here using Matterport's tools. With WP3D Models, you can upload your own image (with your logo, if you like) to customize the image that is posted in this space, on Facebook.
Post 5 • IP   flag post
Richard private msg quote post Address this user
Nice work @rpetersn!

You are a high end user of MP obviously - would you mind perusing my latest post and addressing some or any of my concerns about my issues with MP camera and app today?

R
Post 6 • IP   flag post
3rd Party Service rpetersn private msg quote post Address this user
Looks like I'll need to find more time to digest that one! I'm afraid it sounds like more of a hardware/software issue with the camera & iPad and I'm afraid that's not really my area of expertise. If (with fresh eyes) I think of something, I'll be sure to let you know.
Post 7 • IP   flag post
Basic Fuse private msg quote post Address this user
I have a thumbnail on my scan and canĀ“t get this image to show in FB. Still Matterport logo.
Post 8 • IP   flag post
Forum Founder DanSmigrod private msg quote post Address this user
@Fuse

When I use the Matterport 3D Showcase URL to post to FB, I do not get the Matterport logo. (Example)



Here's what I see when I post to FB using the WP3D Models URL (example)




Can you try posting again and see if you get the same result. If so, please post your URL in this thread so that I can try posting to FB with your URL.

Shameless Plug

I prefer Ross' (@rpetersn) WP3D Models WordPress Plug-in for social sharing. Among other things, I can control the headline and text under the image in social media and the SOURCE is credited to: GALLERY.WE-GET.AROUND.COM

WP3D Models plug-in is free with any 12-month pre-paid membership in the We Get Around Referral Network of Matterport Pro 3D Camera Photographers and Real Estate Agents. (October 2015 only. For details and to Join, please see the Join Referral Network page.

Thanks,

Dan
Post 9 • IP   flag post
3rd Party Service rpetersn private msg quote post Address this user
@DanSmigrod Thanks for the plug(s)!

@Fuse, I suspect the issue is with the OG (Facebook's Open Graph) data being cached at FB. You'll need to go here to clear it:

https://developers.facebook.com/tools/debug/

You'll need to enter the (Matterport) URL you're trying to share and use the "Debug" button. Then you'll likely need to click the resulting "Fetch new scrape information" button a few times. This process will clear out FB's stored information on that URL and should result in the image being retrieved, now that you have a thumbnail set.

Hope that helps!
Post 10 • IP   flag post
Standard StevenHattan private msg quote post Address this user
Ok...I'm just a new guy and still have a 2G phone and a computer with Windows 95 (just kidding about the Windows 95).

Is there anything wrong w this as a FB post? I'm not suggesting a plugin isn't a great solution but why not just have a picture of the property that is scanned and a LINK to the scan on your personal web page?


It takes less than a minute to capture a picture and slap a title on it.

In the mean time, don't apartments in NY have kitchens?
Post 11 • IP   flag post
3rd Party Service rpetersn private msg quote post Address this user
Nope...certainly nothing wrong with that approach.

WP3D Models just makes things really easy by automatically retrieving the thumbnail image from Matterport and creating a unique URL for the model that can be viewed in different ways (Unbranded & MLS compliant, full screen, autoplay, etc.). Additionally, you're provided a custom "embed code" to share with your clients that will allow you to track traffic to that specific model without sending them off to Matterport. The plugin also does all the background legwork to set things up for sharing on FB, Twitter, Pinterest, Google+, etc....and lets you track the traffic that comes back from those sources.

Again though, if you don't need those features...there's absolutely nothing wrong with manually creating a page and embedding the model there, and sharing that page URL on Facebook. Just be sure to get some analytics going on your site so you can see how many people are visiting those pages!
Post 12 • IP   flag post
Basic Fuse private msg quote post Address this user
This is the link : https://my.matterport.com/show/?m=f1BQVPFaW1i It will only show Matterport logo. When I post it on FB !!??
Post 13 • IP   flag post
Forum Founder DanSmigrod private msg quote post Address this user
@Fuse

Hmmmmmm. I tested posting to FB - using your link - and got the same "error" ...

Did you set the thumbnail on the tour or is it black behind the title text?

Dan

Post 14 • IP   flag post
3rd Party Service rpetersn private msg quote post Address this user
Interesting....I still think you're just dealing with a heavily cached (incorrect) image at Facebook, related to first trying to share that model without a thumbnail attached.

I went and tried cleared the OG data for the provided URL (using the process noted in an earlier post) and it should have been share-able with the correct image....but isn't.

Likely this is because there appears to be a hidden redirect built into Matterport that looks for an assigned model thumbnail image...and if it does not find one, it sends FB to this default image:

https://my.matterport.com/images/facebook_embed_default.jpg

So...while you've corrected the issue, somewhere in this redirection process, Facebook is still associating your "thumbnail" to this default image.


Interestingly, even Facebook's own 'sharer' tool now shows the corrected thumbnail...but it still POSTS incorrectly.

See here:
https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fmy.matterport.com%2Fshow%2F%3Fm%3Df1BQVPFaW1i

Maybe it'll clear itself in awhile...otherwise, maybe consider using my WP3D Models plugin...that way you can fully control what image gets sent to when you post/share!
Post 15 • IP   flag post
31257 15 15
destitute