3D, VR and 360° Photographers  |  Real Estate Agents  |  3rd Party Service Providers
Need a 3D/VR/360°/Drone Photographer? 2,567 We Get Around Network Members in 90 Countries! Ask For FREE referral!
We Get Around Network Forum
3D ShowcaseEmbed

Deactivate Fullscreen on ipad582

BLee private msg quote post Address this user
I have searched online and found that by removing the "allowfullscreen" from the iframe embed will deactivate fullscreen. I would like to keep my branding around the embed on the ipad. When I first started scanning my first models the removal of "allowfullscreen" worked fine on ipad by opening up in the iframe (not fullscreen). Recently it started to open fullscreen on ipad even with the "allowfullscreen" removed. Any feedback would be appreciated.
Post 1 • IP   flag post
3rd Party Service rpetersn private msg quote post Address this user
Hi @BLee, chiming in here. My guess here is that Matterport changed some of their local code and is now forcing their models to play fullscreen on various mobile devices, especially iOS-based devices. This force-full-screen is triggered when a user clicks on the "3D Showcase" button and (as you note) it seems to ignore the "allowfullscreen" iframe attribute.

A workaround is to auto-load those models so that a click is not required by the user to load the showcase.

EXAMPLES:

REGULAR EMBEDDED MODEL:
(Requires click, goes full screen on iPad)
http://wp3dmodels.com/3d-model/1900-hollis/

AUTO-LOADING EMBEDDED MODEL:
(No click needed, branding remains on iPad)
http://wp3dmodels.com/3d-model/slant-street-vacation-rental/

SHAMELESS PLUG
On the chance that you'd like to make this all very easy to manage on your (WordPress-based) website, you might be interested in my WP3D Models Plugin.
Post 2 • IP   flag post
31319 2 2
destitute