By the end of December your site has to use php 7.2. Php 5.6 and 7.0 will no longer have security updates supported. 85% of Wordpress uses will be caught off guard on Jan 1. Additionally Wordpress 5.0 is being released and many warn to backup your site before you upgrade to “Gutenberg” aka 5.0 because the editor is brand new and it is already known to conflict you some themes and plugins.

Contact your hosting provider to make sure you upgrade to php7.2 , then get full backup, then research if upgrading to 5.0 will affect you.

Talk to who you trust but we recommend installing the classic editor plugin here

Then install 5.0 and then security patch 5.0.1

But go to your trusted guru and have them look up and advise. Most I talk to are worried about other things and didn’t know.