Connecting 3D/360° Virtual Tour Buyers to Service Providers powered by
the Most In-Depth, Relevant and Up-to-Date Content and Training for the 3D/360° Community
Join FREE! 50+ Benefits
Find a 3D Tour Photographer Map
We Get Around Network Find a Pro Service
Matterport Service Provider? Join We Get Around Network
Photographers
and Real Estate Agents
thinking about adding 24/7
Open House Virtual Tours

will succeed faster with
Virtual Tour Pro
Course
by Ben Claremont”
— Dan Smigrod, WGAN Founder
Coupon Code WGANVTP
One Order  |  One Quote  |  One Contact
Book Multiple USA Commercial Locations
  • ✔  As-Builts
  • ✔  Construction Progress
  • ✔  Facillities Management
Last 24 Hours: 807 Unique Visitors
6,494 WGAN Members in 136 Countries
Last 30 Days: 103,214 Page Views | 27,539 Unique Visitors | 165 New Members
We Get Around Network Forum
WGAN-TV Training U in Matterport
WGAN-TV: Now Playing
High Resolution, Buttery Smooth Videos
Create from Matterport Highlights Reels
Virtual Tour Pro Course
by Ben Claremont
To save 15 Percent, use
Coupon Code: WGANVTP
More Info on Virtual Tour Pro WGAN-TV Program Schedule | Need Help? | Podcast
3D ShowcaseEmbedNewbies

Model is not clickable on mobile1803

nomis11 private msg quote post Address this user
Hi, I'm a newbie here so your help would be greatly appreciated.
I've setup a website and added a model link to the main page. On computer, the website shows the model in certain size and there's "play" button in the middle to start the 3D tour. It works just fine on computer. However, when I try it on my mobile (iPhone or iPad), the initial image of the model shows but the play button in the middle is not clickable. It just won't load the model. I tested the phone on other's website and I can simply click the play button and it will start loading.

Is there a special requirement or HTML code that I need to add on my website? I'm using a template from Wix but before I register a domain and upgrade the account, I need to make sure embeded model is clickable on mobile devices first.

Thanks for your help in advance.
Post 1 IP   flag post
htimsabbub23 private msg quote post Address this user
Can you please. Provide the site we we can look at the source code and see what is causing the issue.
Post 2 IP   flag post
nomis11 private msg quote post Address this user
Sure. Here's a link to one of my test sites:

http://sdshkim.wix.com/sitetest2

It loads from PC or laptop without any issue within a frame but it simply won't do it on mobile device. Other sites with samples work just fine so I know my device is WEBGL compatible.

Thank you!
Post 3 IP   flag post
htimsabbub23 private msg quote post Address this user
There is an option on the server side that turns of this feature on mobile devices. You may have to contact the site hosting server if you can not find it in general settings. When on my phone if I request desktop mode it works juts fine. That tells me in mobile. Mode it is just showing an image and not truly loading the video script. This is very common feature and should be easy to find on your hosting. Enable link for mobile use.
Post 4 IP   flag post
Shane private msg quote post Address this user
I just had a quick look at the code for your site.
There might be a conflict between the width settings.

The first code is your actual 3D Space. It is allowing the width to be 100% of the users screen width with the height restricted to 540.
This generally shows as a full width and can look really good on a site.

The next code is setting the canvas for the 3D Show to run in. This is probably created from the web development software. It is limiting the width to 963.

So my guess is that you might only be seeing the left hand side of the 3D Space (ie of the otherwise wide picture.) On a desktop it interpenetrates the 100% to be of the canvas but on the phone it may be the same case and won't keep the 3D Space within a canvas space.

If you are able to change the 100% in the first code to 963 it might fix the problem.

Of course I could be wrong, but if I was trying to sort it out that would be where I would start.

<iframe src="https://my.matterport.com/show/?m=fRGL4VSosLW" allowfullscreen="allowfullscreen" frameborder="0" height="540" width="100%"></iframe>

<canvas style="width: 963px; height: 540px;" height="540" width="963"></canvas>
Post 5 IP   flag post
Shane private msg quote post Address this user
You might also try the settings in your phone. Some have an option to open internet sites as a desktop rather than a smart phone.
Post 6 IP   flag post
72841 6 6
This topic is archived. Start new topic?