3D, VR, 360° and Street View Photographers  |  Real Estate Agents  |  3rd Party Service Providers
Need a 3D/VR/360°/Street View Photographer? 2,950 We Get Around Network Members in 100 Countries! Ask For FREE referral!
We Get Around Network Forum
Advice

URGENT Workshop 2.0-Do Not Delete 3D Models831

Forum
Founder
DanSmigrod private msg quote post Address this user
All,

I may have discovered a bug in Workshop 2.0 that results in the parent folder being deleted when deleting a child model. For clarification, I deleted a model and it deleted the entire folder that contained that model (and many more models for that client).

While it is possible that I made an error deleting, I do not believe so. I routinely use the delete feature because I frequently re-process models and then delete the older versions, as I was doing this morning. Note that I successfully deleted some models yesterday and earlier this morning, before the folder disappeared.

When I did the delete this morning, I was looking at two models with the same name.

I sent off an URGENT note to Matterport this morning (8:15 am EST Wednesday, 21 October 2015).

I encourage you NOT to delete any models within the 3D Workshop until I hear back from Matterport and post an update here.

Again, it's possible that I made the error.

Do you want to see if you can replicate this with a folder you no longer need by deleting models within it?

Thanks,

Dan
Post 1 • IP   flag post
cdpmedia private msg quote post Address this user
Thanks for the heads up Dan and good luck in the recovery. I am way too gun shy at this point to hit delete on anything!
Say, will you be able to tell us about this Boutique hotel you've been working away on? must be lots of space/sf if involving long days.
Post 2 • IP   flag post
FingFongFang private msg quote post Address this user
Dan,

I think you should be able to recover your lost files as most servers have incremental back up scheme to recover data. I would think that Matterport's cloud server is state of the art.

Thank you again for this information and everything else you have done in the past.
Post 3 • IP   flag post
Forum
Founder
DanSmigrod private msg quote post Address this user
@cdpmedia TY My wife says "bring home a coffee mug, toss a coffee mug" ... trying to be good about deleting earlier versions of the same model.

@FingFongFang fingers, toes and legs crossed. Hoping to hear back from Matterport sooner than later on this.
Post 4 • IP   flag post
Forum
Founder
DanSmigrod private msg quote post Address this user
Good news ...

Matterport Support has restored our folder with 32 models.

We do not know yet if user error (me) or something else.

I encourage you NOT to delete any models until I hear back from Support (and I will post an update here).

Dan
Post 5 • IP   flag post
Forum
Founder
DanSmigrod private msg quote post Address this user
Matterport Support writes:

Here's what *may* have happened:

Is there a chance you click the top-most three dots (see image) and used that Delete, rather than the three dots next to a specific model? Doing so would definitely delete the whole folder, instead of an individual model.

Does that seem reasonable? If you're certain that's not what happened, let [us] know!




I let Support know that user error (me) is possible, because I do this frequently and carefully, I did not feel that I I made this error.

Since I do have many models that I need to delete, I offered to create a an okay to delete folder; load it with models and then start deleting one at a time to see if I could replicate the problem.

Trying to do this tonight (Wednesday, 21 October 2015). I'll update Matterport Support and MUG Forum Members, once I know more.

I encourage you not to delete any models until we know more.

Thanks,

Dan
Post 6 • IP   flag post
Forum
Founder
DanSmigrod private msg quote post Address this user
I was not able to replicate the problem.

I created a folder, added 25 models that I was planning to delete anyway and then deleted one model at a time.

No problem.

While it is possible that is was user error (me), I let Matterport know the results of my testing.

Anyone one else want to create a folder "Okay to Delete" add models and then delete one at a time to see if you can replicate?

Thanks,

Dan
Post 7 • IP   flag post
SBragg private msg quote post Address this user
I almost did this today. Fortunately, I noticed that I was deleting a folder and all of its contents. A need to delete folder is a great idea to prevent a catastrophe.
Post 8 • IP   flag post
Forum
Founder
DanSmigrod private msg quote post Address this user
@SBragg

I am still not able to replicate the problem I described in this thread post.

More than likely, user error (me!).

Dan
Post 9 • IP   flag post
36284 9 9
destitute